Using Quick Mail 2.0.3 to Send Email from WordPress

Please see How to Send Private Comment Replies with WordPress for the latest version of Quick Mail.

Quick Mail WordPress Plugin. Version 2.0.3

Have you ever wanted to send an email with an attachment from the WordPress Dashboard?

You can use my Quick Mail WordPress email Plugin. Quick Mail sends text and html emails with multiple attachments from the WordPress dashboard. Quick Mail includes options to send email to members of your site, or anyone.

Download Quick Mail now, or read on for more information.

Quick Mail was published two years ago. I update Quick Mail when a new version of WordPress is released.

What’s New in Quick Mail 2.0.3?

Quick Mail is usually tested on a site with ten users. However, I discovered that the options screen was confusing on sites with less than 4 users.

Quick Mail 2.0.3 improves the user’s experience on sites with 3 or 4 users. Not many sites, but it was confusing.

I made a basic math error when I added multiple recipients. There must be at least three users on a site for a User List: sender, recipient, CC. Editors need a choice of 4 users, if administrative profiles are hidden.

Previous versions of Quick Mail displayed “User List is not available” aa a useless option. Quick Mail 2.0.3 does not display an options page to Editors if they cannot change the display option.

The downside is that Editors do not have a “Clear Recent Addresses” button, if options are not displayed.

This only affects sites with less than four users. I will try to restore te “Clear” button to Editors, in a future version of Quick Mail.

Other Changes in Quick Mail 2.0.3

Duplicate Email Address

I improved the duplicate email detection. It was annoying to select a different address, because the cursor jumped back to the error.

Clear Saved Addresses

clear recent user message on Quick Mail options In earlier versions of Quick Mail, the “Clear Saved Addresses” message on “Settings,” was not translated.

I moved the function that displays this message to a new file. wp_localize_script translates the Javascript message.

Help Other WordPress Users

A new help message reminds you to help other people.

Please let everyone know that Quick Mail 2.0.3 is compatible with your version of WordPress. I am usually the only person who clicks on the compatibility link.

Get Quick Mail 2.0.3

Quick Mail requires at least WordPress 4.4. WP 4.4 was released a year ago.

Download Quick Mail 2.0.3 from the WordPress Plugin Repository. Fork Quick Mail on GitHub to add new features.

Quick Mail 2.0.3 was tested with WP_DEBUG enabled, on WordPress 4.7, including multisite.

I hope Quick Mail makes your life easier. Please leave a review to help others find it.

Thanks to everyone who has been translating Quick Mail. Please join the translation project so more people can use Quick Mail in their language.

Review my previous articles on Quick Mail for more information. Download Quick Mail to try it now.